0

Mikrotik: настраиваем DHCP для PXE

07.02.2024

https://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server#DHCP_Options

Задача: в локальной сети есть сервер 192.168.88.2 с поднятым TFTPс лежащим на нем образом pxelinux.0, нужно настроить сетевую загрузку для рабочих станций по PXE.

pxelinux.0 можно взять тут: https://mirrors.edge.kernel.org/pub/linux/utils/boot/syslinux/

Решение:

  • IP → DHCP Server → Network
  • Создаем новую или изменяем текущую запись и добавляем:
    • Next Server: 192.168.88.2
    • Boot File Name: pxelinux.0
/ip dhcp-server add address=192.168.88.0/24 gateway=192.168.88.1 dns-server=192.168.88.1 next-server=192.168.88.2 boot-file-name="pxelinux.0" dhcp-option=""

Вариант с созданием Options & Options Set просто так не работает, т.к. необходимо указывать IP сервера новым способом, как описано в документации Mikrotik:

  • IP → DHCP Server → Options
  • Опция 66:
    • Name: option66
    • Code: 66
    • Value: s’192.168.88.2′
  • Опция 67:
    • Name: option67
    • Code: 67
    • Value: ‘pxelinux.0’
  • IP → DHCP Server → Option Sets
    • Name: set-pxe
    • Options: option66, option67
/ip dhcp-server option add name="option66" code=66 value="s'192.168.88.2'" add name="option67" code=67 value="'pxelinux.0'" /ip dhcp-server option sets add name="set-pxe" options=option66,option67

Свежие комментарии

Подписка

Лучшие статьи


Fatal error: Uncaught Error: Call to a member function have_posts() on null in /home/host1867038/the-devops.ru/htdocs/www/wp-content/themes/fox/inc/blog.php:391 Stack trace: #0 /home/host1867038/the-devops.ru/htdocs/www/wp-content/themes/fox/widgets/latest-posts/widget.php(257): fox56_blog_grid(NULL, Array) #1 /home/host1867038/the-devops.ru/htdocs/www/wp-content/themes/fox/widgets/latest-posts/register.php(33): include('/home/host18670...') #2 /home/host1867038/the-devops.ru/htdocs/www/wp-includes/class-wp-widget.php(394): Wi_Widget_Latest_Posts->widget(Array, Array) #3 /home/host1867038/the-devops.ru/htdocs/www/wp-includes/widgets.php(837): WP_Widget->display_callback(Array, Array) #4 /home/host1867038/the-devops.ru/htdocs/www/wp-content/themes/fox/inc/single.php(417): dynamic_sidebar('sidebar') #5 /home/host1867038/the-devops.ru/htdocs/www/wp-content/themes/fox/inc/single.php(136): fox56_single_sidebar() #6 /home/host1867038/the-devops.ru/htdocs/www/wp-content/themes/fox/inc/single.php(7): fox56_single_inner() #7 /home/host1867038/the-devops.ru/htdocs/www/wp-content/themes/fox/single.php(23): fox56_single() #8 /home/host1867038/the-devops.ru/htdocs/www/wp-includes/template-loader.php(106): include('/home/host18670...') #9 /home/host1867038/the-devops.ru/htdocs/www/wp-blog-header.php(19): require_once('/home/host18670...') #10 /home/host1867038/the-devops.ru/htdocs/www/index.php(17): require('/home/host18670...') #11 {main} thrown in /home/host1867038/the-devops.ru/htdocs/www/wp-content/themes/fox/inc/blog.php on line 391