mikrotik

Расширенная инструкция по настройке Hotspot на MikroTik

Данная инструкция является расширенным описанием шага 3 основной инструкции. Здесь подробно описана настройка на роутере, но опущены настройки в личном кабинете Global Hotspot. Поэтому рекомендуем вам вернуться на страницу основной инструкции после выполнения настроек на MikroTik.

Подготовка к настройке

Настройка авторизации пользователей гостевой сети Wi-Fi на MikroTik состоит из следующих этапов:

  1. Создание и настройка гостевого сегмента (bridge).
  2. Подключение интерфейсов к гостевому сегменту.
  3. Настройка авторизации на гостевом сегменте.Если у Вас уже создан гостевой сегмент и настроен интерфейс, то переходите к разделу Настройка Hotspot. Если гостевой сегмент не создан, то к разделу Создание гостевого сегмента для hotspot.

Под гостевым сегментом подразумевается совокупность настроек одного отдельного логического интерфейса (Bridge c настроенным IP адресом и DHCP сервером).

Роутер обязательно должен быть подключен к интернету до начала настройки!

Далее подключите в порт WAN провод с интернетом ( от провайдера ), и соедините Ваш компьютер с любым LAN портом.

Для перехода к следующему пункту необходимо скачать и установить приложение Winbox, оно нужно для управления Вашим роутером Mikrotik.

Если у вас нет доступа в Интернет, то можно скачать урезанную версию WinBox из роутера. Заходим по стандартному адресу для MikroTik http://192.168.88.1 и скачиваем Winbox.

Откройте Winbox, выберите вкладку Neighbors, нажмите Reflesh и перейдите на  адрес роутера.

Укажите логин Admin, пароль по умолчанию отсутствует.

При первом запуске Вам будет предложено применить конфигурацию по умолчанию, после у Вас должен заработать интернет.

Шаг 1. Создание гостевого сегмента для Hotspot

Гостевой сегмент для Hotspot можно создать двумя способами:

  1. через Terminal;
  2. через Winbox или web-интерфейс.

Настройка через Terminal быстрее, но если вы не знакомы с командами RouterOS, то лучше использовать графическую оболочку через Winbox или web-интерфейс.

1.1. Создание сегмента через Terminal

Откройте Terminal в Winbox либо подключитесь к нему по ssh. Для создания гостевого сегмента достаточно выполнить скрипт ниже:

 /interface bridge add name="HS_bridge" disabled=no auto-mac=yes protocol-mode=rstp
 /ip address add address=10.50.50.1/24 interface=HS_bridge comment="CaptivePortalV8 network" network=10.50.50.0
 /ip pool add name=hs-pool-3 ranges=10.50.50.2-10.50.50.254
 /ip dhcp-server add address-pool=hs-pool-3 disabled=no interface=HS_bridge lease-time=1h name=dhcp1
 /ip dhcp-server network add address=10.50.50.0/24 comment="hotspot network" gateway=10.50.50.1

1.2. Создание сегмента через Winbox в режиме GUI

1.2.1. Добавление интерфейса

Перейдите в раздел Bridge и добавьте новый интерфейс. Укажите имя HS_bridge

1.2.2. Добавление IP адреса

Перейдите в раздел IP/Adresses, добавьте новый адрес сети, и укажите интерфейс HS_bridge который мы создали. Нажмите OK.

1.2.3. Настройка DHCP сервера

Переходим в раздел IP/DHCP Server/DHCP Setup и добавляем новый DHCP сервер

В качестве интерфейса указываем HS_bridge, жмем Next указываем параметры которые предлагает Mikrotik по умолчанию либо устанавливаем свои.

Выбираем сеть для DHCP сервера по умолчанию.

Указываем шлюз по умолчанию.

Указываем пул IP адресов, по необходимости его можно разделить либо уменьшить.

Указываем Lease Time, время аренды IP адреса, при необходимости его можно увеличить либо уменьшить.

Указываем адреса DNS. При необходимости можете указать DNS от Yandex без сайтов для взрослых:

77.88.8.7
77.88.8.3

Либо оставить DNS от Google, или прописать свои адреса.

Таким образом мы создали новый DHCP сервер на интерфейсе HS_bridge.

На этом настройка гостевого сегмента закончена.

Шаг 2. Добавление интерфейсов

В зависимости от реализации Вы можете добавить интерфейсы на Mikrotik разными способами:

1. При использовании внутреннего Wi-Fi на Mikrotik (WLAN).
2. При использовании CAPsMAN.
3. При использовании VLAN.
4. При использовании ETHER.

Выберите подходящий вариант для вашей топологии сети.

Шаг 3. Настройка Hotspot

Настроить Hotspot можно двумя способами:

  1. через Terminal;
  2. через Winbox или web-интерфейс.

Настройка через Terminal быстрее, но если вы не знакомы с командами RouterOS, то лучше использовать графическую оболочку через Winbox или web-интерфейс.

3.1. Настройка Hotspot через Terminal

Для создания Hotspot нужно выполнить скрипт:

 /radius add service=hotspot address=5.101.126.175 secret=captive_v8_radpass timeout=3000ms
 /ip hotspot profile add hotspot-address=10.50.50.1 name=hsprof1
 /ip hotspot add address-pool=hs-pool-3 disabled=no interface=HS_bridge name=hotspot1 profile=hsprof1
 /ip hotspot user add name=admin
 /ip hotspot profile set hsprof1 use-radius=yes
 /ip hotspot profile set hsprof1 login-by=http-pap
 /ip hotspot set numbers=hotspot1 idle-timeout=none
 /ip hotspot user profile set numbers=default keepalive-timeout=4d
 /ip hotspot walled-garden ip add dst-address=5.101.126.175/32
 /ip hotspot walled-garden ip add dst-address=91.230.211.75/32
 /ip hotspot walled-garden ip add dst-address=46.229.213.165/32
 /ip hotspot walled-garden ip add dst-address=188.225.18.2/32
 /ip hotspot walled-garden ip add dst-address=188.225.73.64/32
 /ip hotspot walled-garden ip add dst-address=87.236.23.242/32
 /ip hotspot walled-garden add dst-host=*.global-hotspot.ru
 /ip hotspot walled-garden add dst-host=v8.global-hotspot.ru
 /ip hotspot walled-garden add dst-host=*.glhs.ru

Если у Вас гостевой сегмент имеет другую IP адресацию, то при создание конфигурации в личном кабинете выберите Уже настроенное устройство (Только настройки Hotspot) укажите другой ip адрес гостевой сети, и в самом скрипте укажите другой interface для hotspot и address-pool.

Пример:

Если вы желаете, чтобы Mikrotik передавал параметры в личный кабинет Global hotspot для его мониторинга, то выполните блок предварительно скопировав его из конфигурации:

На этом настройка Hotspot через Terminal окончена.

3.2. Настройка Hotspot через Winbox

Перейдите в раздел IP/Hotspot/Server/Hotspot Setup

В качестве интерфейса указываем HS_bridge.

Выбираем IP адрес сети Hotspot, указываем Masquerade Network для автоматического создания правила Masquerade в Firewall/NAT.

Указываем пул IP адресов для Hotspot.

Указываем SSL сертификат, если его нет то укажите none.

SMTP server можно указать пустое значение.

DNS адреса для Hotspot, можно оставить по умолчанию, либо указать свои.

DNS name можно указать пустое значение.

Во вкладке Server Profiles выберите профиль который мы создали hsprof1 в окне Login укажите тип авторизации HTTP PAP, в окне RADIUS укажите Use RADIUS.

3.2.1. Настройка Walled Garden

Добавляем в Walled Garden и в Walled Garden IP List  ip адреса и хосты для исключения

5.101.126.175/32
91.230.211.75/32
46.229.213.165/32
88.225.18.2/32
88.225.73.64/32
87.236.23.242/32


*.global-hotspot.ru
v8.global-hotspot.ru
*.glhs.ru

Можно выполнить скриптом:

/ip hotspot walled-garden ip add dst-address=5.101.126.175/32
/ip hotspot walled-garden ip add dst-address=91.230.211.75/32
/ip hotspot walled-garden ip add dst-address=46.229.213.165/32
/ip hotspot walled-garden ip add dst-address=188.225.18.2/32
/ip hotspot walled-garden ip add dst-address=188.225.73.64/32
/ip hotspot walled-garden ip add dst-address=87.236.23.242/32


/ip hotspot walled-garden add dst-host=*.global-hotspot.ru
/ip hotspot walled-garden add dst-host=v8.global-hotspot.ru
/ip hotspot walled-garden add dst-host=*.glhs.ru

Либо в ручную:

3.2.2. Настройка планировщика ( Scheduler )

Копируем из конфигурации скрип для добавления планировщика в Mikrotik для мониторинка вашего Mikrotik и выполняем в терминале

3.2.3. Настройка Radius

Перейдите в раздел RADIUS и добавьте новый radius сервер.

 Service: hotspot 
 Address: 5.101.126.175 
 Secret: captive_v8_radpass 
 Timeout: 3000ms

Для настройки через терминал достаточно выполнить команду

/radius add service=hotspot address=5.101.126.175 secret=captive_v8_radpass timeout=3000ms

При подключение к сети с hotspot, ваше устройство должны появится в разделе IP/Hotspot/Host и на девайсе отобразится страничка с порталом авторизации

После успешной регистрации устройство должно появится в разделе IP/Hotspot/Active

Данная инструкция является расширенным описанием шага 3 основной инструкции. Здесь подробно описана настройка на роутере, но опущены настройки в личном кабинете Global Hotspot. Поэтому рекомендуем вам вернуться на страницу основной инструкции после выполнения настроек на MikroTik.

Previous Story

VLAN switching на устройствах Mikrotik

Next Story

Настройка двух Интернет-каналов (резервирование)

Latest from Blog

KeyCloak SSO

перевод статьи: https://cloudinfrastructureservices.co.uk/install-keycloak-sso-on-ubuntu-20-04/ Keycloak – это бесплатное решение для управления идентификацией и доступом с открытым исходным кодом

FreeRADIUS и Daloradius

Что такое сервер freeRADIUS? RADIUS — это протокол AAA (аутентификация, авторизация и учет), который помогает контролировать

Установка и настройка HAProxy на Linux

Данная инструкция применима для Linux CentOS и Ubuntu. Мы рассмотрим как процесс установки, так и примеры настройки. УстановкаПринцип настройки 

0 £0.00